Reading Linux

Aug 28, 2008 07:24 # 45981

Jimi * posts about...

Ubuntu and the Compaq Laptop: An Elegy

About a month ago, I had begun to investigate Linux operating systems. I was anxious enough to enter into this wonderful sub-culture that I installed it on my girlfriend's laptop (with her permission, of course).

This was my first mistake.

The laptop, a Compaq Presario C700, was obviously budget level and nothing special. Of course, it was all Audrey, my girlfriend, had, but she despised Vista just as much as I, so she was willing to experiment. Of course, I assumed everything would work out nicely. The only foreseeable problem was the incompatibility with the Atheros wireless card... It couldn't possibly be that hard to work around, could it?

Well, it could, and was. This caused her computer to be repeatedly rendered useless in all wireless and some wired situations. To make things worse, the notebook wasn't ready for her when she went off to college, which put a lot of unnecessary strain on her. I persisted with every form of Madwifi and ndiswrapper and anything else I could come by... Hours and hours and hours of sleepless nights were dedicated to fixing the internet connectivity, but all to no avail.

There was one option left, however: to reinstall Vista.

Now, being a poor 20 year old, I've only ever purchased one PC up to this point. It was a Dell, which came with all of the discs needed for a full XP reinstallation. Naturally, I assumed similar discs were provided for HP products, which sort of emboldened my boldness in the first place.

This, my dear friends, was my last and most fateful error.

Proving my complete ignorance, I discovered that the only method of Windows reinstallation was through a system recovery partition that is installed on the system a la factory. Even after purchasing a $20 system recovery disc, the damage was done; there was nothing left to recover. Vista had been completely erradicated from my computer. The only thing to boot to left on the laptop is the Hitachi HTS542580K9SA00, which possesses all 80 GB's of the system and which is completely data-less.

So, what is there left to do? Well, I could send the laptop in to have it repaired (have another version of Windows Vista completely installed) for the small fee of $300. Or, I could buy Windows Vista Home Basic for $200. Or... I could reinstall Linux and keep up the good fight.

But for now, brothers... I rest. Weary from the timeless struggle, I can find a calm sort of peace in this message:

"BOOTMGR is missing
Press Ctrl+Alt+Del to restart"

Epilogue

If I'm wrong anywhere here or you think you can suggest a solution to my problem... Please, feel free. Here were my outputs when Ubuntu was functional...

lspci -nn:

00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [8086:2829] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 03)
01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
02:01.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)

lsmod:

Module                  Size  Used by
ipv6                  267780  10 
af_packet              23812  2 
i915                   32512  2 
drm                    82452  3 i915
rfcomm                 41744  2 
l2cap                  25728  13 rfcomm
bluetooth              61156  4 rfcomm,l2cap
ppdev                  10372  0 
acpi_cpufreq           10796  1 
cpufreq_stats           7104  0 
cpufreq_powersave       2688  0 
cpufreq_ondemand        9740  1 
cpufreq_userspace       5284  0 
cpufreq_conservative     8712  0 
freq_table              5536  3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
container               5632  0 
sbs                    15112  0 
sbshc                   7680  1 sbs
dock                   11280  0 
iptable_filter          3840  0 
ip_tables              14820  1 iptable_filter
x_tables               16132  1 ip_tables
parport_pc             36260  0 
lp                     12324  0 
parport                37832  3 ppdev,parport_pc,lp
joydev                 13120  0 
snd_hda_intel         344728  2 
snd_pcm_oss            42144  0 
snd_mixer_oss          17920  1 snd_pcm_oss
snd_pcm                78596  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
snd_seq_dummy           4868  0 
snd_seq_oss            35584  0 
snd_seq_midi            9376  0 
snd_rawmidi            25760  1 snd_seq_midi
snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
video                  19856  0 
output                  4736  1 video
snd_seq                54224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24836  2 snd_pcm,snd_seq
psmouse                40336  0 
snd_seq_device          9612  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ac                      6916  0 
wmi_acer                9644  0 
serio_raw               7940  0 
iTCO_wdt               13092  0 
button                  9232  0 
battery                14212  0 
snd                    56996  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
intel_agp              25492  1 
iTCO_vendor_support     4868  1 iTCO_wdt
shpchp                 34452  0 
pci_hotplug            30880  1 shpchp
evdev                  13056  7 
pcspkr                  4224  0 
agpgart                34760  3 drm,intel_agp
soundcore               8800  1 snd
ext3                  136712  1 
jbd                    48404  1 ext3
mbcache                 9600  1 ext3
sr_mod                 17956  0 
cdrom                  37408  1 sr_mod
ata_generic             8324  0 
sg                     36880  0 
8139too                27520  0 
sd_mod                 30720  3 
ata_piix               19588  0 
ahci                   28420  2 
pata_acpi               8320  0 
libata                159344  4 ata_generic,ata_piix,ahci,pata_acpi
scsi_mod              151436  4 sr_mod,sg,sd_mod,libata
8139cp                 24704  0 
mii                     6400  2 8139too,8139cp
ehci_hcd               37900  0 
uhci_hcd               27024  0 
usbcore               146028  3 ehci_hcd,uhci_hcd
thermal                16796  0 
processor              36872  4 acpi_cpufreq,thermal
fan                     5636  0 
fbcon                  42912  0 
tileblit                3456  1 fbcon
font                    9472  1 fbcon
bitblit                 6784  1 fbcon
softcursor              3072  1 bitblit
fuse                   50708  3

iwconfig:

lo        no wireless extensions.

eth0      no wireless extensions.

The version is Ubuntu Hardy 2.6.24-19-generic on a 32-bit laptop. Thanks in advance!

Breathe.

This post was edited by Jimi on Aug 28, 2008.

Aug 28, 2008 12:19 # 45983

null throws in his two cents...

Re: Ubuntu and the Compaq Laptop: An Elegy

I'm afraid I have no idea how to get the Linux thing running... basically everything I'd have suggested, you've already tried.

A friend of mine solved a similar problem by installing a PCMCIA WLAN card with a well-supported chipset... while not the best or most satisfying solution, it works.

If you think it's worth a try I could send you an HP/Compaq recovery DVD for Windows Vista and XP Professional (if your computer comes with Vista Business or 'better', I think you're eligible for a free updowngrade to XP Pro). The DVD doesn't require a recovery partition. Of course I can't promise that it will work on your laptop.

When life hands you a lemon, that's 40% of your RDA of vitamin C taken care of.

Aug 28, 2008 12:46 # 45986

hexKid * has an idea...

Re: Ubuntu and the Compaq Laptop: An Elegy

That's a shame, man. Have you considered just getting a network adapter that has drivers already designed and well reviewed for Ubuntu? They can't be that expensive, I have an old one in my laptop I can give you, though I'm not sure if it's drivers are supported.

I'd hate to see you spend $200-300 for an OS.


Small text Large text

Netalive Amp (Skin for Winamp)